Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Problem Uploading Database

Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
Board Member

Joined: 05 Jan 2010

Posts: 3

PostPosted: Tue Jan 05, 2010 6:55 pm 
Post subject: Problem Uploading Database

Hi there!

I have an old backup of a board which we used to have running on, and I'm having trouble with getting the damn thing to work, so looking for help!

I followed these steps below...

lumpy burgertushie wrote:
you have the steps sort of mixed up.

here is the proper way to do it:

1. install phpbb on the new host with a new database

2. restore your old database backup to the new one.

3. upload the new install folder again and in your browser, go to:

delete the install folder again and you are done.

you will need to reset the domain name and script and cookie path in the admin panel or use the cookie MOD to do it for you.


I first attempted to upload the database file with the built in database restore thing in the admin panel. After a long time of waiting, i was just met with a blank screen, saying "powered by phpbb 2001" or something like that, instead of it saying it had successfully uploaded it. I went back to the index page, and it was just the same as if i had installed a fresh copy. One post, and all the default stuff, and nothing had seemed to change.

I thought i'd try and upload the database using phpmyadmin. After a while it said it had successfully done it.

I went to the index page to check, and now it's just a white screen. Not even an error message - just absolutely nothing. icon_eek.gif

So any help getting it to work would be much appreciated!

I know there is nothing wrong with the database, because last year i had it working when i installed it to the harddrive using xampp.

I'll provide any more details you may need if you need to know more!

Thanks very much.

Back to top
Board Member

Joined: 19 Nov 2008

Posts: 541
Location: North West UK

PostPosted: Tue Jan 05, 2010 8:28 pm 
Post subject: Re: Problem Uploading Database

Is the information that is in the file config.php correct for that database?
Does it contain the correct database name, username and password?
When you restored it with phpmyadmin did you see the tables appear in the left hand column?


The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
Board Member

Joined: 05 Jan 2010

Posts: 3

PostPosted: Tue Jan 05, 2010 10:51 pm 
Post subject: Re: Problem Uploading Database

Hi Jim!

The backup was purchased from freeforums in 2008, and i was sent just a zip file with the backup file inside. There was no other files with it.

I had trouble at the time getting it to work, but gave up and started again with a fresh copy of phpbb3.

After a while i heard about installing the forum to your HD with xampp, so i spent some time playing about with that, and eventually got it to work. Someone said i had to change some server setting in phpmyadmin from to Was so long ago, i can't remember what i have to do now! icon_redface.gif

The values in config.php are correct as far as i'm aware. They match the new database i created for it.

When i uploaded the backup file with phpmyadmin, all the columns on the left showed up too.

Just that when i go to the main page, i'm just met with a white screen.

My config.php


// phpBB 2.x auto-generated config file
// Do not change anything in this file!

$dbms = 'mysql4';

$dbhost = 'localhost';
$dbname = 'infinite_oldforum';
$dbuser = 'infinite_ant';
$dbpasswd = '************';

$table_prefix = 'infinitelove_';

define('PHPBB_INSTALLED', true);


It's not urgent, and i got plenty of time to sort this thing out!

Also I'm lacking in experience when it comes to playing around with databases, and server settings. I just know the absolute basics, and don't play around with settings i don't understand. icon_biggrin.gif

 Filesize:  61.28 KB
 Viewed:  368 Time(s)


Back to top
Board Member

Joined: 05 Jan 2010

Posts: 3

PostPosted: Wed Jan 06, 2010 12:03 am 
Post subject: Re: Problem Uploading Database

Got it sorted!

It was because i uploaded a style that obviously wasn't the right one. I went into phpmyadmin, and changed the style value to the default one.

Now it works! I came so close to giving up, and just forgetting about it completely, lol.

Where there's a will there's a way! icon_wink.gif

Though it really needs sorting out. The freeforums one had lots of mods installed, and this one hasn't. Gonna spend some time sorting that out!

Thanks very much anyways, and i wish you and everyone else on this forum the very best for the future!

icon_biggrin.gif icon_biggrin.gif icon_biggrin.gif icon_biggrin.gif
Back to top
Sylver Cheetah 53
Board Member

Joined: 17 Dec 2008

Posts: 426
Location: Milky Way

PostPosted: Thu Jan 07, 2010 2:48 pm 
Post subject: Re: Problem Uploading Database

Just a suggestion: You can use border="0" for the images in your forums descriptions. icon_smile.gif
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0209 seconds using 17 queries. (SQL 0.0027 Parse 0.0025 Other 0.0157)
phpBB Customizations by the
Template Design by DeLFlo and Moments of Light Logo