phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Attachment Mod


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
pmoore603
Board Member



Joined: 07 Jun 2010

Posts: 1



PostPosted: Mon Jun 07, 2010 7:48 pm 
Post subject: Attachment Mod

Been using phpBB2 with the attach mod (Acyd Burn's) for a long time now, and only just today noticed that the attach mod was not displaying attached files for PM's or for preview (PM or post). Thought I'd share the corrections. Apologies if this is the wrong forum for this.

Replace {ATTACHMENTS} with {postrow.ATTACHMENTS} in the install.doc file. This affects three files: privmsgs_read_body.tpl, privmsgs_preview.tpl, and posting_preview.tpl. Just make the change yourself in the three files if it's already installed. Here is what should be in the install doc for the three related changes:


Code:
#
#-----[ OPEN ]---------------------------------------------
#
templates/subSilver/posting_preview.tpl

#
#-----[ FIND ]---------------------------------------------
# around line 13
               <span class="postbody">{MESSAGE}</span>

#
#-----[ AFTER, ADD ]---------------------------------------
# Do NOT make one line out of this, a <!-- --> template statement has to be on one seperate line
               <!-- BEGIN postrow -->
               {postrow.ATTACHMENTS}
               <!-- END postrow -->






#
#-----[ OPEN ]---------------------------------------------
#
templates/subSilver/privmsgs_preview.tpl

#
#-----[ FIND ]---------------------------------------------
# around line 23
   <td valign="top" colspan="2" class="row1"><span class="postbody">{MESSAGE}</span></td>

#
#-----[ REPLACE WITH ]---------------------------------------
# Do NOT make one line out of this, a <!-- --> template statement has to be on one seperate line
   <td valign="top" colspan="2" class="row1"><span class="postbody">{MESSAGE}</span>
   <!-- BEGIN postrow -->
   {postrow.ATTACHMENTS}
   <!-- END postrow -->
   </td>






#
#-----[ OPEN ]---------------------------------------------
#
templates/subSilver/privmsgs_read_body.tpl

#
#-----[ FIND ]---------------------------------------------
# around line 47
     <td valign="top" colspan="3" class="row1"><span class="postbody">{MESSAGE}</span></td>

#
#-----[ REPLACE WITH ]---------------------------------------
# Do NOT make one line out of this, a <!-- --> template statement has to be on one seperate line
     <td valign="top" colspan="3" class="row1"><span class="postbody">{MESSAGE}</span>
<!-- BEGIN postrow -->
   {postrow.ATTACHMENTS}
<!-- END postrow -->
     </td>
Back to top
Holger
Board Member



Joined: 19 Jan 2009

Posts: 509
Location: Hanover


flag
PostPosted: Wed Jun 09, 2010 7:06 am 
Post subject: Re: Attachment Mod

Hm, strange.
I have the attachments shown in the preview. Cannot remember fixing that!

Thank you anyway!
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Fri Jun 18, 2010 12:28 am 
Post subject: Re: Attachment Mod

That didn't seem to work on our installation
_________________
http://www.jlaforums.com
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 541
Location: North West UK


flag
PostPosted: Fri Jun 18, 2010 11:11 am 
Post subject: Re: Attachment Mod

How about just turning on the option to show them!!! icon_lol.gif


Jim



snip.JPG
 Description:
 Filesize:  38.95 KB
 Viewed:  410 Time(s)

snip.JPG


Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Fri Jun 18, 2010 4:23 pm 
Post subject: Re: Attachment Mod

Jim_UK wrote:
How about just turning on the option to show them!!! icon_lol.gif


Jim


Would be nice if it were that simple Heh heh!

_________________
http://www.jlaforums.com
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0121 seconds using 17 queries. (SQL 0.0026 Parse 0.0024 Other 0.0071)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo