phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

2.0.23 or 2.0.24 for PHP 5.4
1 members found this topic helpful
Goto page 1, 2  Next
 
Search this topic... | Search phpBB2 Discussion... | Search Box
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Author Message
cpreston
Board Member



Joined: 21 Apr 2013

Posts: 3



PostPosted: Mon Apr 22, 2013 4:17 am 
Post subject: 2.0.23 or 2.0.24 for PHP 5.4

I found two posts. One lists a bunch of code changes to make 2.0.23 compatible with recent versions of PHP. There lists a bunch of code changes to be at 2.0.24 (I think that's what it's saying).

Which should I do? Does one include the other?
Back to top
dogs and things
Board Member



Joined: 18 Nov 2008

Posts: 621
Location: Spain


flag
PostPosted: Mon Apr 22, 2013 7:38 am 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

I am running phpBB2.0.23 on PHP 5.3.23.

So far I did not have to make any codechanges to phpBB to make it compatible with newer PHP versions ever since I started upgrading PHP from it's initial version 4.3.

I never bothered to update phpBB to .24 because I'm afraid I'll run into problems due to installed MODs being incompatible with the new code. I don't think my particular board is at risk for not applying .24.

_________________
phpBB2 will never die, I hope!
Back to top
achaab
Board Member



Joined: 06 Dec 2012

Posts: 11



PostPosted: Tue Apr 23, 2013 7:45 am 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

@ cpreston : The changes for the 2.0.24 are only here to fix some phpBB bugs. It doesn't help you with the compatibility of phpBB with PHP 5.4+

I suggest you to install both (first the 2.0.24 fix and then the php 5.4 fix), i dont think you will have any problem even if the php 5.4 fix has been made for phpbb 2.0.23.

In case you have any trouble because 1 line is not the same in phpbb 2.0.24, you can download my forum here and check what is the moddified line for a phpbb 2.0.24 (the website is in french but there is only 1 button so you should be ok. Click on it and it will start the download)



@ dogs and things : unless you have many ptirhiik's mods, you should not be afraid to do the update icon_wink.gif
With a lot of mods installed i didnt have any problem ^^
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Thu May 23, 2013 10:32 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

We added the .24 update to our own - and there are heavy modifications on our site
_________________
http://www.jlaforums.com
Back to top
Coroner
Board Member



Joined: 23 Sep 2013

Posts: 1



PostPosted: Mon Sep 23, 2013 3:05 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

Hello Folks. I was not aware that there is a 2.0.24 version of phpBB2? I am running a heavily modded 2.0.23 version and would be interested in what changes and or features this would have. Could someone please post a link to the update?

Thank you for your time.....

_________________
Image link
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Mon Sep 23, 2013 3:51 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

Coroner wrote:
Hello Folks. I was not aware that there is a 2.0.24 version of phpBB2? I am running a heavily modded 2.0.23 version and would be interested in what changes and or features this would have. Could someone please post a link to the update?

Thank you for your time.....


http://www.phpbb2refugees.com/viewtopic.php?t=203

_________________
http://www.jlaforums.com
Back to top
StarWolf3000
Board Member



Joined: 10 Jun 2010

Posts: 86
Location: Germany


flag
PostPosted: Mon Sep 23, 2013 3:57 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

phpBB 2.0.24 was not officially announced and published. It was a work in progress release for phpBB 2, containing several fixes and security enhancements.

The 2.x line was discontinued at the 2.0.23 release, which was the last official and public release. The code for a particular 2.0.24 remains in the CVS and Git repositories, even a complete update instruction set was packaged.

Work on it begun directly after the official release of 2.0.23, but they decided to stop development on the 2.x line in favor for phpBB 3.

Several sites and users published the installation instructions, even phpBB 2.0.23 with the 2.0.24 updates preinstalled.

If you want the installation instructions, look around here on the board and/or ask potential users. Also you can do a global internet search with "phpbb 2.0.23 to 2.0.24".

Together with the PHP 5.3/5.4 fixes found in another topic, you should be able to use it on recent PHP versions.
Back to top
Dog Cow
Board Member



Joined: 18 Nov 2008

Posts: 378


flag
PostPosted: Mon Sep 23, 2013 5:50 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

StarWolf3000 wrote:
phpBB 2.0.24 was not officially announced and published. It was a work in progress release for phpBB 2, containing several fixes and security enhancements.


To clarify: it is a work in progress from the phpBB Group, not some third party. It might have been released on phpbb.com if the 2.0.x series was still current.

_________________
Moof!
Lincoln's Tomb, Oak Ridge Cemetery, Springfield IL Mac 512K Blog Mac GUI
Back to top
lord.nitos
Board Member



Joined: 13 Oct 2012

Posts: 4
Location: /root


flag
PostPosted: Sat Oct 12, 2013 9:11 am 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

I don't understand, sorry... Is the 2.0.24 avaliable or not?
Back to top
StarWolf3000
Board Member



Joined: 10 Jun 2010

Posts: 86
Location: Germany


flag
PostPosted: Sat Oct 12, 2013 12:43 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

It is available, but not from the phpBB Group.

The attached file contains the upgrade instructions (requires you to have a 2.0.23 installation) and the database update file. While the upgrade instructions require 2.0.23, the database update file can be executed on any 2.0 release, even the Release candidates (RC).



phpBB-2.0.24-codechanges.zip
 Description:
phpBB 2.0.23 to 2.0.24 code changes

Download
 Filename:  phpBB-2.0.24-codechanges.zip
 Filesize:  13.66 KB
 Downloaded:  861 Time(s)

Back to top
dondino
Board Member



Joined: 09 Dec 2008

Posts: 144


flag
PostPosted: Tue Oct 15, 2013 2:33 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

.... has anyone tried already to upgrade to php 5.5.x ? icon_rolleyes.gif
Back to top
Ultimos Homo Statans
Board Member



Joined: 10 Feb 2012

Posts: 4



PostPosted: Fri Aug 28, 2015 11:42 am 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

Can anybody post phpBB 2.0.24? Not code changes! I only have 2-3 MODs and I am ready to give them up. icon_wink.gif
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Fri Aug 28, 2015 3:28 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

There is no authorised phpBB2.0.24 as the phpbb.com group stopped the support and development at 2.0.23
If you use the search you should be able to find the code changes, which were produced by a member here, should you want to make them.
I have left mine at 2.0.23

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
lumpy burgertushie
Board Member



Joined: 19 Nov 2008

Posts: 216


flag
PostPosted: Mon Aug 31, 2015 11:09 pm 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

old MODs is really the only good reason not to upgrade to phpbb3

is there some reason why you do not want to go to phpbb3?

there are a lot more features and security fixes etc.


robert
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Wed Sep 02, 2015 2:47 am 
Post subject: Re: 2.0.23 or 2.0.24 for PHP 5.4

PHPBB2 is a great platform and is can be scaled to the sky. It seems it is easier to work with (tweaking) than phpbb3. Starting from scratch - you might be better with phpbb3 unless you find a fully developed phpbb2 fork that has everything you need/want.
_________________
http://www.jlaforums.com
Back to top
Display posts from previous:   
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT
Goto page 1, 2  Next
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0160 seconds using 17 queries. (SQL 0.0023 Parse 0.0028 Other 0.0109)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo