phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

moved servers - now register page wont load

Goto page 1, 2  Next
 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Wed Nov 19, 2014 10:31 pm 
Post subject: moved servers - now register page wont load

Hi,
my host recently moved my phpbb 2.18 forum to another server and transferred all the files. Everything works except the register function ( profile.php ?), the page does not load.


Any advice? thanks.


The host said it may be something to do with the code, which I will paste below in case its of use to you:

if ( isset($HTTP_GET_VARS['mode']) || isset($HTTP_POST_VARS['mode']) )
{
$mode = ( isset($HTTP_GET_VARS['mode']) ) ? $HTTP_GET_VARS['mode'] : $HTTP_POST_VARS['mode'];
$mode = htmlspecialchars($mode);

if ( $mode == 'viewprofile' )
{
include($phpbb_root_path . 'includes/usercp_viewprofile.'.$phpEx);
exit;
}
else if ( $mode == 'editprofile' || $mode == 'register' )
{
if ( !$userdata['session_logged_in'] && $mode == 'editprofile' )
{
redirect(append_sid("login.$phpEx?redirect=profile.$phpEx&mode=editprofile", true));
}

include($phpbb_root_path . 'includes/usercp_register.'.$phpEx);
exit;
}
else if ( $mode == 'confirm' )
{
// Visual Confirmation
if ( $userdata['session_logged_in'] )
{
exit;
}

include($phpbb_root_path . 'includes/usercp_confirm.'.$phpEx);
exit;
}
Back to top
dogs and things
Board Member



Joined: 18 Nov 2008

Posts: 621
Location: Spain


flag
PostPosted: Wed Nov 19, 2014 10:58 pm 
Post subject: Re: moved servers - now register page wont load

My guess is that your new server has a newer version of PHP running and that you will fix this problem applying the fix proposed in this post by asavage.

Tip: read that whole topic to better understand the problem.

_________________
phpBB2 will never die, I hope!
Back to top
Salvatos
Board Member



Joined: 19 Feb 2009

Posts: 416
Location: Québec


flag
PostPosted: Thu Nov 20, 2014 6:31 am 
Post subject: Re: moved servers - now register page wont load

That would be my first guess as well.
Back to top
nostro
Board Member



Joined: 16 Jul 2012

Posts: 54


flag
PostPosted: Thu Nov 20, 2014 7:31 am 
Post subject: Re: moved servers - now register page wont load

Or if it's only failing profile.php maybe this one:
http://www.phpbb2refugees.com/viewtopic.php?t=1189
http://www.phpbb2refugees.com/viewtopic.php?p=7957#7957
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Thu Nov 20, 2014 8:54 am 
Post subject: Re: moved servers - now register page wont load

If the problem is the same that Dave experienced then the line in question in profile.php is

Code:
if ( !$userdata['session_logged_in'] && $mode == 'editprofile' )


and his solution was to replace "&&" with "&"

Jim
Back to top
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Thu Nov 20, 2014 10:09 am 
Post subject: Re: moved servers - now register page wont load

Hi all,

thanks for the quick replies!

Jim_UK, I will try that first as that seems easiest.

If I have to implement what asavage suggested, can someone walk me through how to edit the code in the relevant php files? It seems you can do them automatically using some software or command but I'm not sure how.


My server hosting package uses cPanel.

Thanks.
Back to top
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Thu Nov 20, 2014 1:13 pm 
Post subject: Re: moved servers - now register page wont load

Hi all, I tried the & solution but it never worked.

icon_sad.gif
Back to top
dogs and things
Board Member



Joined: 18 Nov 2008

Posts: 621
Location: Spain


flag
PostPosted: Thu Nov 20, 2014 3:21 pm 
Post subject: Re: moved servers - now register page wont load

Basics for opening and editing phpBB files.
_________________
phpBB2 will never die, I hope!
Back to top
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Thu Nov 20, 2014 5:40 pm 
Post subject: Re: moved servers - now register page wont load

Hi,
I can edit individual files ok, but it seems I need to check all php files and find&replace a certain section of code. I thought I could do them all in one go with some sort of command line software? Ssh software or something?

I'm not familiar with these programmes, but is this possible? thanks
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 66



PostPosted: Thu Nov 20, 2014 6:48 pm 
Post subject: Re: moved servers - now register page wont load

I don't see how the proposed solution could ever work.

What I'm getting instead is that call-time pass-by-reference has been removed and that's failing, so a function called with a `&` parameter must have the ampersand moved to its signature.

_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Thu Nov 20, 2014 8:00 pm 
Post subject: Re: moved servers - now register page wont load

Vendethiel wrote:
I don't see how the proposed solution could ever work.


Do you mean the fix suggested by asavage?

Quote:

What I'm getting instead is that call-time pass-by-reference has been removed and that's failing, so a function called with a `&` parameter must have the ampersand moved to its signature.


Can you clarify what I need to do to check this? Thanks.
Back to top
newbie999
Board Member



Joined: 19 Nov 2014

Posts: 8



PostPosted: Sat Nov 22, 2014 2:27 pm 
Post subject: Re: moved servers - now register page wont load

Would upgrading to phpbb 3 resolve this problem?
Back to top
nostro
Board Member



Joined: 16 Jul 2012

Posts: 54


flag
PostPosted: Sat Nov 22, 2014 4:16 pm 
Post subject: Re: moved servers - now register page wont load

newbie999 wrote:
Would upgrading to phpbb 3 resolve this problem?

Sure, but it will probably also create new problems for you.
Back to top
knowit
Board Member



Joined: 17 Dec 2015

Posts: 7



PostPosted: Mon Dec 21, 2015 1:46 am 
Post subject: Re: moved servers - now register page wont load

We're you ever able to resolve this? If so what was the fix? My board has the same errors. Blank registration page and the call time pass by removed error. I am not a web guy so not sure what to do. Any help is most appreciated.
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 66



PostPosted: Mon Dec 28, 2015 2:21 am 
Post subject: Re: moved servers - now register page wont load

Is there no displayed error/stack trace?
_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 2 All times are GMT
Goto page 1, 2  Next
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0157 seconds using 15 queries. (SQL 0.0017 Parse 0.0007 Other 0.0133)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo