phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Strange behaviour.


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 551
Location: North West UK


flag
PostPosted: Thu Jan 22, 2015 9:41 pm 
Post subject: Strange behaviour.

I have had one of my members make a post which seemingly contains no text at all. I saw the post and wondered why he would do such a thing but thought no more of it until he posted later to say that he could click "Edit" and see his post text.
I have checked and that is so. Does anyone have any idea what might cause this to happen? The text is clearly there in the database and is linked to this post but just not visible!!
Not sure if it helps but here is the post in question http://controlline.org.uk/phpBB2/viewtopic.php?p=145321#145321

I have just tried quoting the post ans I get a blank post.
However there was a url in the post which I have removed and now it is visible. Very strange. Any ideas?
More info - The url had a missing bracket in closure tag ie [url

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 663
Location: Texas


flag
PostPosted: Fri Jan 23, 2015 6:33 am 
Post subject: Re: Strange behaviour.

It probably broke the rendering process with invalid HTML. Have you installed any BBCode MODs, or anything that would affect the way the post text and embedded tags are processed?
_________________
phpBBDoctor Blog
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 551
Location: North West UK


flag
PostPosted: Fri Jan 23, 2015 8:13 am 
Post subject: Re: Strange behaviour.

Quite a lot of Dave. As this has only happened once perhaps the easiest way out is just to tell my members to make sure that they use the closing bracket.
If they use the highlight text and click the "url" button then it is there so it is either someone edited after doing that or attempted to type it in direct and omitted it.

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 663
Location: Texas


flag
PostPosted: Wed Jan 28, 2015 12:33 am 
Post subject: Re: Strange behaviour.

My concern would be if you've opened yourself up to some sort of vulnerability due to the lack of proper rendering with a missed tag.
_________________
phpBBDoctor Blog
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 551
Location: North West UK


flag
PostPosted: Wed Jan 28, 2015 7:45 am 
Post subject: Re: Strange behaviour.

Where would you start looking Dave? (includes/bbcode.php)
Most of the mods added that have been bbcode related were done such a long time ago.

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0263 seconds using 15 queries. (SQL 0.0027 Parse 0.0008 Other 0.0228)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo