phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Can you run phpBB2 on Centos7 and newer versions of php?


 
Search this topic... | Search phpBB2 Discussion... | Search Box
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Author Message
Lynx
Board Member



Joined: 23 Feb 2015

Posts: 7


flag
PostPosted: Thu Sep 08, 2016 12:15 pm 
Post subject: Can you run phpBB2 on Centos7 and newer versions of php?

My current phpBB2 is on Centos5, which will no longer be supported next year.

Are there any issues with Centos7 or newer versions of php? I am currently using PHP Version 5.2.17.

p.s. I just noticed this great post:
http://phpbb2refugees.com/viewtopic.php?p=1420#1420

I need to move the smaller of my two phpBBs to a cheap test site and see what happens.

That said, is anyone using any version of php7?
https://secure.php.net/releases/
Back to top
lumpy burgertushie
Board Member



Joined: 19 Nov 2008

Posts: 217


flag
PostPosted: Thu Sep 08, 2016 3:25 pm 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

since neither phpbb 3.0 or 3.1 will work on php 7 I seriously doubt phpbb 2 will work without some major changes.

robert
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 69



PostPosted: Thu Sep 08, 2016 7:53 pm 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Well, the other one is magic_quotes, but it's no issue. So really I think it's going to be fine (programming is my dayjob and I have 10 years of php experience. I'll deal with it if I have to, even if I spend some time doing it...).
_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
Lynx
Board Member



Joined: 23 Feb 2015

Posts: 7


flag
PostPosted: Fri Sep 09, 2016 12:35 am 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Are there any security issues with disabling magic quotes?

I found this doing a search:
Searching for: magic_quotes
common.php(29): set_magic_quotes_runtime(0); // Disable magic_quotes_runtime
common.php(96): // addslashes to vars if magic_quotes_gpc is off
common.php(100): if( !get_magic_quotes_gpc() )
admi\admin_db_utilities.php(450): if(get_magic_quotes_runtime())
Found 4 occurrence(s) in 2 file(s)

If I remember right, the poster I found said to just comment out this line:
common.php(29): set_magic_quotes_runtime(0); // Disable magic_quotes_runtime

changed:
common.php(29): //set_magic_quotes_runtime(0); // Disable magic_quotes_runtime

I'm trying to figure out if I really want to upgrade my phpbb2. I did convert the more active forum to be responsive (am moderately happy with results). All the modifications I did years ago to clean up the board, I'd do all again.
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 69



PostPosted: Sun Sep 11, 2016 2:50 pm 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Quote:
Are there any security issues with disabling magic quotes?
No. They're disabled anyway. But you might get an error because the functions related to it were removed.

The $_GET/$_POST thing will be a bit more annoying.
Changing class to use __construct will be okay.
A few other things need updating.

_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
Lynx
Board Member



Joined: 23 Feb 2015

Posts: 7


flag
PostPosted: Sun Sep 11, 2016 3:41 pm 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

So this is much more complicated than Dog Cow's post describes?

1) commenting out the magic quotes
2) changing the php.ini file to turn unicode.semantics = off
3) making some changes to sessions.php

Are there any comprehensive directions out there? Or will I really just have to switch to php3?

I was hoping somehow to avoid all this work but I want the board functional years from now.
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 69



PostPosted: Tue Sep 13, 2016 7:11 pm 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Depends what you call "complicated". I don't have PHP7 installed, so I can't confirm or deny anything yet.
_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
Lynx
Board Member



Joined: 23 Feb 2015

Posts: 7


flag
PostPosted: Fri Sep 16, 2016 12:12 am 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Looks like php 5.6 would be a better choice than php7. The thread I originally found with tips had to do with php6 which appears to have been sidelined.

Has anyone gotten phpbb2 to work using php5.6?
Back to top
Vendethiel
Board Member



Joined: 26 Oct 2014

Posts: 69



PostPosted: Sat Sep 17, 2016 8:50 am 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

I have several (premodded0 boards running PHP 5.5. According to this page, 5.6 shouldn't break anything else.
_________________
Developer on EzArena, the ADR premod.
Developer on Icy Phoenix, the phpBB hybrid cms.
Developer on IntegraMOD.
Back to top
Lynx
Board Member



Joined: 23 Feb 2015

Posts: 7


flag
PostPosted: Sat Sep 17, 2016 10:53 am 
Post subject: Re: Can you run phpBB2 on Centos7 and newer versions of php?

Thanks. I will give it a shot (will try my softly modded board).
Back to top
Display posts from previous:   
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0270 seconds using 15 queries. (SQL 0.0020 Parse 0.0009 Other 0.0241)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo