phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Older PHPBB2 install needing updates


 
Search this topic... | Search phpBB2 Discussion... | Search Box
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Author Message
ttyR2
Board Member



Joined: 03 Jul 2013

Posts: 6



PostPosted: Sat Dec 17, 2016 6:56 pm 
Post subject: Older PHPBB2 install needing updates

I set up a phpBB2 board back in 2005 for a friend of mine. I heavily modified it at the time (look and feel stuff) and have been hesitant to want to go to that much work again with PHPBB3.

I haven't done any updates for quite some time and need help to figure out where I'm at and how to proceed. Currently the board is hosted at 1&1 and they have been great. They did force an upgrade in MySQL versions which caused problems, but they fixed that themselves. Something changed about a month ago and now users are reporting frequent "No posts exist for this topic" when clicking on various messages. I thought I could reproduce it only when logged in, but now (a few days later) it seems to happen at random times even if I'm not logged into the board.

The board is currently phpBB2 version 2.0.19, and I have EasyMOD 0.3.0 installed to do updates. Like I said...I haven't done much in the way of updates for a long time.

So...any idea what is causing the "No posts exist for this topic" error message? How do I go about fixing it? And...if updates are all that are needed, can I go directly to phpBB2 2.0.23 or do I have to upgrade in steps?

I think 1&1 has us running php 5.5 or newer.
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 556
Location: North West UK


flag
PostPosted: Sat Dec 17, 2016 9:00 pm 
Post subject: Re: Older PHPBB2 install needing updates

I am not sure what is causing you the problems on your site but can tell you that you can't upgrade from 2.0.19 to 2.0.23 all in one go. You will have to perform each upgrade one at a time.

The files you need are here https://sourceforge.net/projects/phpbb/files/phpBB%202/

Good luck - I hope your problem is sorted when you do the upgrades.
If not post back and we may have someone that can help you.

Jim

Edit I am running phpBB2 on PHP5.5 without experiencing the errors that you are.

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
ttyR2
Board Member



Joined: 03 Jul 2013

Posts: 6



PostPosted: Sun Dec 18, 2016 1:57 am 
Post subject: Re: Older PHPBB2 install needing updates

If you are familiar with easyMOD....I vaguely recall that I used it to do upgrades in the past, but I'm not finding much in the way of documentation saying how to do that now. The last time I used it was probably in 2006 or so.

Have any of you guys used easyMOD to do updates?
Back to top
ttyR2
Board Member



Joined: 03 Jul 2013

Posts: 6



PostPosted: Sun Dec 18, 2016 2:34 am 
Post subject: Re: Older PHPBB2 install needing updates

Ok...I figured out how to use easyMOD again. When I do a preview, it throws an error on one of the files it is going to update when using the 2.0.19->2.0.21 code changes file, but seems happy with the other file changes it is going to make.

Critical Error

FIND FAILED: In file [admin/admin_board.php] could not find:

'AUTOLOGIN_TIME' => (int) $new['max_autologin_time'],
"BOARD_EMAIL_FORM_ENABLE" => $board_email_form_yes,
"BOARD_EMAIL_FORM_DISABLE" => $board_email_form_no,
"MAX_POLL_OPTIONS" => $new['max_poll_options'],
"FLOOD_INTERVAL" => $new['flood_interval'],

MOD script line #150 :: FAQ :: Report

CRITICAL ERROR: Could not modify [admin/admin_board.php]

I didn't delete any of that stuff...and the board says it's running at version 2.0.19. Should I go back and re-apply the 2.0.18->2.0.19 changes file?
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 556
Location: North West UK


flag
PostPosted: Sun Dec 18, 2016 7:27 am 
Post subject: Re: Older PHPBB2 install needing updates

I found that the more mods I had installed the less likely Easymod was to succeed installing others.
Also because the updates to phpBB2 itself were very important I never used it for that but did all upgrades manually that allowing you to look for similar if not identical code.
I note that you say it failed with 2.0.19 to 2.0.21
Surely you mean 2.0.19 to 2.0.20 otherwise you have missed out one step.

You must apply them one step at a time.

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
ttyR2
Board Member



Joined: 03 Jul 2013

Posts: 6



PostPosted: Sun Dec 18, 2016 7:06 pm 
Post subject: Re: Older PHPBB2 install needing updates

Yes, sorry. 2.0.19 to 2.0.20.

So...if it's failing with just that one item, is it NOT safe to proceed with the other patches?
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 556
Location: North West UK


flag
PostPosted: Sun Dec 18, 2016 7:19 pm 
Post subject: Re: Older PHPBB2 install needing updates

Apply the code changes manually.
Easymod can fail if a mod you have installed has changed the core files.
A find instruction that hits an unknown that you have inserted into a line will cause it to fail. If you do the edits manually you can take just a section of the "find" in a line and identify the line that needs to be edited.
Easymod worked just fine for some things when I tried it but fell down as I had more and more files edited due to mods.
The standard phpBB2 install has about 30 database tables but mine has near 100 due to all the mods I installed. Vast numbers of lines have been edited to include references to those fields in the extra tables so Easymod struggles with my site if it involves edits to the core files.

Apply each step one at a time and then test to see if the error disappears. Don't stop though until you have applied all the updates.
All I can tell you is that mine still functions ok on PHP5.5

There is of course another possibility for the error showing and that is that the post was deleted before you went to it. I take it you have eliminated that possibility?

Jim

_________________
The truth is out there.
Unfortunately they will not let you anywhere near it!
Back to top
Display posts from previous:   
Register or Login to Post    Index » phpBB2 Discussion  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0269 seconds using 15 queries. (SQL 0.0024 Parse 0.0009 Other 0.0237)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo