phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

Topic watch not starting


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
Sylver Cheetah 53
Board Member



Joined: 17 Dec 2008

Posts: 426
Location: Milky Way


flag
PostPosted: Wed Dec 17, 2008 8:35 pm 
Post subject: Topic watch not starting

Hy!

I am using phpBB 2.0.22. When I check notify me when a reply is posted, topic watch is not started. I do not get reply notifications, but only if I click watch this topic for replies. icon_sad.gif

What could be the cause of this problem? icon_confused.gif

_________________
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Wed Dec 17, 2008 8:59 pm 
Post subject: Re: Topic watch not starting

Do you not get notification of the first post after your own?
The notify me of replies is not for every reply in that topic - just the one that follows your own.
Now of course the Watch topic is another thing completely and you should get a notification for every post.

Jim
Back to top
Sylver Cheetah 53
Board Member



Joined: 17 Dec 2008

Posts: 426
Location: Milky Way


flag
PostPosted: Wed Dec 17, 2008 9:02 pm 
Post subject: Re: Topic watch not starting

I did not knew that they are different things. icon_confused.gif No, I do not get a notification after first reply, but I get notifications for new private messages, so I guess the SMTP server is not the issue (I am using Gmail).
_________________
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Wed Dec 17, 2008 9:08 pm 
Post subject: Re: Topic watch not starting

Some systems barf at emails to "Undisclosed recipient".
Check your spam box to see if those are going into it. You may be able to set up an exception to the rule.
I think that there is a change you can make to the code that will get around it though assuming that it is your own board we are talking about.
Go onto phpbb.com and do a search for "undisclosed recipient"

Jim
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 653
Location: Texas


flag
PostPosted: Thu Dec 18, 2008 1:52 am 
Post subject: Re: Topic watch not starting

If you want to see if the code is broken, check the phpbb_topics_watch table. Try this test:

Go into a topic that you have not posted in before.
Reply, and click "Notify me when a reply is posted" during that process.
No go to the database and check to see if there is a row in the phpbb_topics_watch table for your user_id value and the selected topic_id. If there is no row, then the process is broken and no notification will be sent out.

You can repeat the test using the "Watch this topic" link you mentioned. What you will probably find is that the second option does insert a row into the table.

Jim_UK is also correct in that it could be a mail issue, but by checking this table you can see if there is something wrong with the code on your board as well.

_________________
phpBBDoctor Blog
Back to top
Sylver Cheetah 53
Board Member



Joined: 17 Dec 2008

Posts: 426
Location: Milky Way


flag
PostPosted: Thu Dec 18, 2008 9:52 pm 
Post subject: Re: Topic watch not starting

I am user number 3. I've posted in topic ID 63, but there is no topic ID 63 for user ID3. icon_confused.gif Not with notify_status 0, not with notify_status 1, not at all. What could this mean? icon_sad.gif
_________________
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Fri Dec 19, 2008 12:12 pm 
Post subject: Re: Topic watch not starting

Assuming that you are checking in the correct place then the likely cause is that you have installed a mod that has broken it.
A mod can be installed and all seems to be working fine but how often do we test every little function after the install?

Jim
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 653
Location: Texas


flag
PostPosted: Fri Dec 19, 2008 11:20 pm 
Post subject: Re: Topic watch not starting

So the code that is supposed to do that is in function user_notification() found in includes/functions_post.php. What you could do to debug this is check the status of the variable $notify_user just prior to the function call from posting.php. In a standard 2.0.23 it's about line 596.
Code:
                if ($error_msg == '' && $mode != 'poll_delete')
                {
                        user_notification($mode, $post_data, $post_info['topic_title'], $forum_id, $topic_id, $post_id, $notify_user);
                }

The code in that function first checks to make sure a reply is being made, so that notifications are not sent out on edits. Which, by the way, is a MOD I have seen requested. icon_smile.gif Getting notified of post edits too. But I digress. After other notification emails have been sent out, the last bit of the function checks to see if you are watching the topic. If you are, you stop watching it. If you are not, you start watching it. This should insert a row into the watched topics table for the next time someone replies.

_________________
phpBBDoctor Blog
Back to top
Sylver Cheetah 53
Board Member



Joined: 17 Dec 2008

Posts: 426
Location: Milky Way


flag
PostPosted: Sat Dec 20, 2008 10:35 am 
Post subject: Re: Topic watch not starting

That line seems to be okay.
Code:
update_post_stats($mode, $post_data, $forum_id, $topic_id, $post_id, $user_id);
}

if ($error_msg == '' && $mode != 'poll_delete')
{
user_notification($mode, $post_data, $post_info['topic_title'], $forum_id, $topic_id, $post_id, $notify_user);
}

if ( $mode == 'newtopic' || $mode == 'reply' )

icon_sad.gif

_________________
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
drathbun
Board Member



Joined: 24 Jul 2008

Posts: 653
Location: Texas


flag
PostPosted: Sat Dec 20, 2008 5:11 pm 
Post subject: Re: Topic watch not starting

Does the value of $notify_user get passed correctly? Put in an "echo" statement to check...

Also is anyone else on the board experiencing the same issue?

_________________
phpBBDoctor Blog
Back to top
Sylver Cheetah 53
Board Member



Joined: 17 Dec 2008

Posts: 426
Location: Milky Way


flag
PostPosted: Sat Dec 20, 2008 9:19 pm 
Post subject: Re: Topic watch not starting

Please, do not get upset on me, but I do not know what is an echo statement. icon_redface.gif Also, I do not know what means "$notify_user get passed correctly". icon_redface.gif Sorry for being n00b... Also, I do not understand all english words.

90% of the users seems to experience the same problem. Only a 2-3 people say their notifications works perfectly.

_________________
Image link
My Forum || My Blog

phpBB2 forever! icon_smile.gif
Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0121 seconds using 15 queries. (SQL 0.0019 Parse 0.0003 Other 0.0098)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo