phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

[BETA] Stupid Bots 0.2.0

Goto page Previous  1, 2, 3
 
Search this topic... | Search MOD Development... | Search Box
Register or Login to Post    Index » MOD Development  Previous TopicPrint TopicNext Topic
Author Message
Dog Cow
Board Member



Joined: 18 Nov 2008

Posts: 378


flag
PostPosted: Mon Jun 01, 2009 10:23 pm 
Post subject: Re: Stupid Bots 0.2.0

JLA wrote:
What specifically should I be looking for in this?

Thanks


You're looking for REQUEST_URI

_________________
Moof! Email me: dog_cow@macgui.com
Inside Allerton Park Lincoln's Tomb, Oak Ridge Cemetery, Springfield IL Mac 512K Blog
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Mon Jun 01, 2009 10:51 pm 
Post subject: Re: Stupid Bots 0.2.0

Yes, there is no request_uri
_________________
http://www.jlaforums.com
Back to top
Dog Cow
Board Member



Joined: 18 Nov 2008

Posts: 378


flag
PostPosted: Mon Jun 01, 2009 11:53 pm 
Post subject: Re: Stupid Bots 0.2.0

JLA wrote:
Yes, there is no request_uri

Well, that's the source of the problem.

How are your Apache and PHP configured? Are you running PHP as an Apache module, or as CGI/FastCGI?

_________________
Moof! Email me: dog_cow@macgui.com
Inside Allerton Park Lincoln's Tomb, Oak Ridge Cemetery, Springfield IL Mac 512K Blog
Back to top
JLA
Board Member



Joined: 30 Apr 2009

Posts: 298
Location: U.S.A


flag
PostPosted: Tue Jun 02, 2009 1:44 am 
Post subject: Re: Stupid Bots 0.2.0

Dog Cow wrote:
JLA wrote:
Yes, there is no request_uri

Well, that's the source of the problem.

How are your Apache and PHP configured? Are you running PHP as an Apache module, or as CGI/FastCGI?


We are not running Apache. IIS with FastCGI

_________________
http://www.jlaforums.com
Back to top
Ptirhiik
Board Member



Joined: 19 Nov 2008

Posts: 114


flag
PostPosted: Tue Jun 02, 2009 6:01 am 
Post subject: Re: Stupid Bots 0.2.0

Caution with superglobals ($_SERVER, $_GET, $_POST, etc.) : they are unset in common.php if register_globals is on (what it shouldn't, but anyway).

A quick workaround for IIS REQUEST_URI (not the cleanest, but effective on most servers):
Code:
if ( !isset($_SERVER['REQUEST_URI']) )
{
   $_SERVER['REQUEST_URI'] = substr($_SERVER['PHP_SELF'], 1);
   if ( isset($_SERVER['QUERY_STRING']) && $_SERVER['QUERY_STRING'] )
   {
      $_SERVER['REQUEST_URI'] .= '?' . $_SERVER['QUERY_STRING'];
   }
}

nb.: once more, here I should have use in phpBB context $HTTP_SERVER_VARS in place of $_SERVER.
Back to top
Dog Cow
Board Member



Joined: 18 Nov 2008

Posts: 378


flag
PostPosted: Mon Aug 24, 2009 8:22 pm 
Post subject: Re: Stupid Bots 0.2.0

If you want to allow Lynx users to access your site, I suggest changing 'libwww' in the user-agent list to instead read 'libwww-perl'
_________________
Moof! Email me: dog_cow@macgui.com
Inside Allerton Park Lincoln's Tomb, Oak Ridge Cemetery, Springfield IL Mac 512K Blog
Back to top
Display posts from previous:   
Register or Login to Post    Index » MOD Development  Previous TopicPrint TopicNext Topic
Page 3 of 3 All times are GMT
Goto page Previous  1, 2, 3
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0215 seconds using 15 queries. (SQL 0.0141 Parse 0.0002 Other 0.0072)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo