phpBB2Refugees.com Logo
Not affiliated with or endorsed by the phpBB Group

Register •  Login 

Continue the legacy...

Welcome to all phpBB2 Refugees!Wave Smilie

This site is intended to continue support for the legacy 2.x line of the phpBB2 bulletin board package. If you are a fan of phpBB2, please, by all means register, post, and help us out by offering your suggestions. We are primarily a community and support network. Our secondary goal is to provide a phpBB2 MOD Author and Styles area.

f.a.p. 1.4.1 single user can't see pics


 
Search this topic... | Search General Support... | Search Box
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Author Message
boblo
Board Member



Joined: 29 Dec 2009

Posts: 5
Location: Big Rapids, MI but wishing I was on Bois Blanc Island


flag
PostPosted: Sun Jan 24, 2010 12:24 am 
Post subject: f.a.p. 1.4.1 single user can't see pics

Did a fresh install of 2.0.23 over Christmas break and have been tweaking it ever since. I did not run the install script, just updated the tables in the db so they'd have all the current rows, etc and copied old config.php to the fresh install. Since installing I've added in this order:
    easymod0.4.0,
    ezPortal v2183e,
    full album pack 1.4.1,
    Admin_Userlist_2,
    security_question_1.1.0,
    show_last_visited_users_1.0.0,
    Topic Calendar v1.2.2
    added recent & random pic's to the portal page using contrib file from fap

Next problem to solve. I have one user who can see the thumbnail pic's on portal.php and also album.php. However, when he clicks the thumbnail he gets the dreaded Red X. I sent him a test username and password to use and here are his e-mails to me:
    2:31PM - Rob - That worked!! I can see the pics - Now what??
    2:57PM - Since I logged in with your test, I went back and logged in with my password/username and Walla!! – It seem to be working – Can get pics now!!
    2:59PM - Whoops – I reopened the site with my login and had to go back to your login to make it work again?????
    4:16PM - Latest report – Seems like it’s working now under my saved username/password
    Did you do something or did me logging out and back in do something??(I was taking a nap thru all these e-mails)
    6:20PM - Well – after rebooting the computer, I find that the only way I can view Pics is to sign up with your username/password – Thought it was working for a while, but it must have been remembering your password………….Ron
As far as I know, pic's work fine for all my other members. I'm not sure where to look to figure this out. Here's the link for fap www.phpbbhacks.com/download/5028

Anybody have any suggestions? Thanks.

_________________
long live phpBB2
Back to top
Salvatos
Board Member



Joined: 19 Feb 2009

Posts: 416
Location: Québec


flag
PostPosted: Sun Jan 24, 2010 3:08 am 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

Too tired to have a look at the MOD, but my first reaction if I were you would be to check if there are any noticeable differences in the database between this member and "all the others". For instance, is he more recent, older, does he have different permissions, different settings, etc.

But even before that, I would have him/her delete their cookies and cache to make sure it's not their browser's fault. Maybe also try another browser if they have more than one at their disposal.
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Sun Jan 24, 2010 11:44 am 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

I would do absolutely nothing.

If you have one person with a problem viewing these images and all else can see them then it is their set up that is wrong and nothing at all to do with your site.
My first thoughts were that he had some sort of image blocker running that was screening out images of a certain size (sometimes used to screen out small pop ups)
Second thought was that you had not set the permissions correctly in the FAP control panel but that does not explain why it is only him.

Very odd.
Can you post a link to what he is reporting as showing missing images.

Jim
Back to top
boblo
Board Member



Joined: 29 Dec 2009

Posts: 5
Location: Big Rapids, MI but wishing I was on Bois Blanc Island


flag
PostPosted: Mon Jan 25, 2010 7:47 pm 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

Jim,

Link to the site is http://www.bois-blanc.com

Here are his e-mails from yesterday:
    10:38AM - Rob - I deleted my cookies and temp files again - Now it seems to be working??????? Fingers crossed!!

    11:29AM This one will get you - I got back on the computer after shutting it down - Had to renter my username/password and I could see the pics - Went to another site and came back and could not see them - I logged out and then I could see them????????? Don't it like my name or should I change username and password and see what happens??


???? icon_confused.gif

_________________
long live phpBB2
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Mon Jan 25, 2010 9:24 pm 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

I see hardly any of the thumbnails - see attached image.
Clicking the text I do see the full size one though.

Jim



Capture.JPG
 Description:
 Filesize:  37.36 KB
 Viewed:  498 Time(s)

Capture.JPG


Back to top
Salvatos
Board Member



Joined: 19 Feb 2009

Posts: 416
Location: Québec


flag
PostPosted: Mon Jan 25, 2010 9:26 pm 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

Well well well, let's see what we have here.

1. One user cannot see the pictures using his own account.
2. On another account, he seems to see them fine.
3. However, after deleting his cookies and relogging in, he can see the images on both accounts.

At first glance, this tells me there is a problem with auto-login or his cookies. I will assume that he is not the only user out of 1,038 to use this function, however, so chances are his cookies are the problem. Let's keep searching for clues.

4. Since he can view the thumbnails on portal.php and album.php, the error has to occur on album_showpage.php... Unless he is getting a bad link from portal.php/album.php, since the MOD uses a pic_id system that will likely display the page "correctly" no matter what id is entered.

As far as I'm concerned, that's far as I can get into the reasoning since I don't know how the MOD works exactly. There are two things I would check (except for the aforementioned browser switch).

First, I would have him log into the test account, activate auto-login, leave the site and come back sometime later. If the images show up, you'll know that the problem is specific to his account. If they don't, you'll know that something on his computer is to blame.

Another thing would be to check if he gets the right URL for the pictures (for instance, compare the URL you get for a particular with the one he gets for the same image).

I just saw that... album_showpage.php calls the image from a PHP file (album_picm.php):
Code:
<a href="album_showpage.php?full=true&amp;pic_id=2580"><img src="album_picm.php?pic_id=2580" border="0" vspace="10" alt="Black Medick" title="Black Medick" /></a><br />
         <span class="genmed">Click on image to view larger image&nbsp;</span><br />

Is he using Google Chrome? If not, which browser? Maybe it does not accept PHP images. I don't know why it would work when he has a fresh cookie and not otherwise, but I'm thinking that his browser definitely is to blame. Have him make sure that it is up to date and/or try another one to see how that goes.
Back to top
Jim_UK
Board Member



Joined: 19 Nov 2008

Posts: 544
Location: North West UK


flag
PostPosted: Mon Jan 25, 2010 9:38 pm 
Post subject: Re: f.a.p. 1.4.1 single user can't see pics

I am using Firefox 3.5.7 and the thumbnails are missing in the portal view (that showing random images) but are there when I view it in IE8

See what I see in the portal with Firefox.

I must point out that I also have FAP and I see all the thumbnails on my own site.

Jim



Capture2.JPG
 Description:
 Filesize:  136.9 KB
 Viewed:  501 Time(s)

Capture2.JPG


Back to top
Display posts from previous:   
Register or Login to Post    Index » General Support  Previous TopicPrint TopicNext Topic
Page 1 of 1 All times are GMT
 
Jump to:  

Index • About • FAQ • Rules • Privacy • Search •  Register •  Login 
Not affiliated with or endorsed by the phpBB Group
Powered by phpBB2 © phpBB Group
Generated in 0.0164 seconds using 17 queries. (SQL 0.0023 Parse 0.0027 Other 0.0113)
phpBB Customizations by the phpBBDoctor.com
Template Design by DeLFlo and MomentsOfLight.com Moments of Light Logo